Deleted some of the database but it still appears on the answers?

I’ve created a course and then edited it to delete some of the database but it still appears on the answers, why does it do that?
or have I done it wrong?

I’ve checked all the database on my course and all of them are correct, but when I test the course all the database that I had initially and was deleted still appear in the course.

I can’t get my head around it, is there something buggy with the software?

has anyone else had the same issue before and if so how did you solve it?

1 Like

It’s a bug that has unfortunately been around for years, I believe. If I understand it correctly, when the text is put in or altered for any field of any item in the database, it draws from everything else that is currently in that same column to generate the options for multiple choice questions. This means that it does not update those options to reflect changes to the other items unless forced to.

It’s quite a hassle, but I’ve heard users say that they’ve been able to fix it by adding a character to a field that’s showing outdated options, clicking out of the box to save it, then removing the extra character again, before doing the same for every other item in the same way. It’s important to remove the extra character before continuing to the next entry though, or else you’ll end up with a bunch of options with the extra character floating around in the end.

This is obviously very time-consuming, and downright impractical for larger databases. I unfortunately don’t know of any easier way to update them though. It’s important to note that I have not tested this myself, so I wouldn’t suggest trying it out for the first time on a course you’ve spent a lot of time building, as I can’t guarantee that it won’t somehow make the problem worse.

Edit: There’s a script here, however, which may be worth a look:

1 Like

Thank you. It looks like I’m stuck with it as I don’t even know where they are to edit them as they don’t exist in the course now, but I still see them on tests. Well, we just have to keep it for now. I have no other choice by the looks of it.

If it’s a big issue affecting the usability of your course then I’d suggest copying the entries that you have now onto a new course to get rid of the phantom entries.

You will lose your learning history on any items - it’s a matter of deciding whether it’s worth doing for better long term use.

For future reference - It’s better to edit an entry in the database (change it to something you want on the course) than to delete it!

To clarify, it isn’t the deleted entries you would need to edit, but the ones that are showing outdated options when you’re being tested on them.

Say for example you had two items in a database:


You later decide to change “green” to “blue”, but since the options had already been generated for “red”, “green” would still show up in the multiple choice tests for “red”. The idea would be to temporarily change “red” to anything, say “red1”, for example, thus forcing it to reset its set of options and look through the database again. Since “green” is no longer there, it would use “blue” instead. You would then be able to change the same entry back to “red”.

1 Like

The problem is I’ve alreadt deleted the database entries, so I can’t see them when I try to edit the course, they just are not there. It looks like I’m stuck, I have a lot of people on it with high scores and I don’t want to delete and start over from fresh.

Why don’t you try the userscript (by @neoncube) TinyCaterpillar linked to? It’s solved the problem in my courses.

because the script is for outdated options, not for deleted entries… and because is extremely time consuming… otherwise, I agree with @leggi, better to edit than to delete y personal workaround: edit in a new tab/open edit in a new tab, after edit, close the tab, and then hit “back” in the learning/review page/tab to go back to the level/course page… I have less phantom entries with this method

And why exactly do you think that would not work for deleted entries? You do not get any more outdated. The idea of the script to force an update on the generated multiple choice answers (for all current words in the course).

I believe the script should work in his case as well.

@ErolOzvatan, I know it’s annoying, but I would encourage you to try to run the script. I and others have used it on several courses, and it seems to work well.

because I have tried it… and it did not help (and got me sick with so much tinkering). I will not reinstall it.

I don’t know what to do with this script.
What is it and how to use it? where to install it?
I have no idea how to make a use of it.

The script can be found below.

If you’d like to run the script, you need to do these three things:

  1. Install the Greasemonkey extension (if you’re using Firefox) or the Tampermonkey extension (if you’re using Chrome)
  2. Install the script.
  3. Go to your course’s levels page and run the script.

The instructions for #2 and #3 are in the link that I posted.

If you need any help, just let us know :slight_smile:


Thank you!

1 Like

You’re welcome!

As I said, let us know if you need any help. Getting the userscript running is tricky for some people.

the script “try to eliminate phantom entries” does not give the message “finished”

Hi @nescioso,

It looks like something changed on the Memrise servers about a month ago, and the script hasn’t really been working since then, sorry.

@neoncube do you have any plans on working on this in the near future …?
Here’s a few virtual beers for motivation: :beer::beer::beer::beer: and :beers:! :wink:

@Olaf.Rabbachin Haha, ah… hard to say. Honestly, my motivation for this is kind of low at the moment, but I appreciate the encouragement :slight_smile:

1 Like