Deleted/old answers still appearing in tests


(Set Free) #83

I guess the problem continues. My experience is exactly the same as yours.

I created my first course only today. As part of that creation process I imported several entries by mistake; these contained characters such as >;’", etc. I deleted them from the course and from the database, but those deleted entries are appearing amongst the possible answers in my tests. Where are they being drawn from?..


(pdao) #84

@SetFree ~ I no longer have an issue with “phantom” answers in the one course that I manually removed them from. @DrewSSP gave instructions on how to delete them, both thru a script process and a manual process, and I opted for the manual process and it worked like a charm. It took a while, but I also took the opportunity to make a few changes to the course at the same time, so it was a win-win for me.

If you read further up this thread you will see @DrewSSP 's explanation of how/where the “phantom” answers reside, and how to vanquish them. He did a great job of detective work on this issue and provided a relatively painless means of eradication.

The “phantom” answers are not visible to course creators at either the database level or course levels, but if you read what @DrewSSP wrote, you will see where the pesky little buggers reside and why they can only be eradicated with the instructions he provided. His process works ~ and I am manually applying it to a second course now !!! :smiley:


(Set Free) #85

@pdao and @DW7. Thank you both for your helpful suggestions and DrewSSP for tracking down the problem. The code looks a bit complex for me so I will try the manual approach.

Can I ask, when you change an entry, save it, then change it back and save it again, are you doing that in the database or the section where the Levels are? If I click on ‘Databases’ and then select my database, there is no ‘Save and Continue’ button like there is in the normal ‘Levels’ editing section.


(pdao) #86

@SetFree ~ I made all my manual changes in the database(s) of the course, not the respective course levels. I also always used the same extraneous character for my changes (the @ symbol) since none of my words in the course contained or ended with that character. This way, if I somehow forgot to delete the extraneous character during my final save of a change, the @ symbol seen during a course level preview, or future test, would be a clear sign that I needed to go back and remove it. Luckily, I went slow enough that I did not miss any. Good luck with your changes. They really work !!!

Edit: Sorry, but I meant to write that I made the changes at the Database level, not the various course levels. I really should proofread my postings before I submit them. :disappointed: I will change the text above to reflect the correct response since people may not read this edit notice.

And you don’t need a Save and Continue button. Just make your changes in the Database then click on the Back to Course button (which saves the changes) then click on the Edit Course button and select your Database again and repeat this process for as many changes as you need to make. It goes by quickly once you get the hang of it.


(pdao) #87

To any interested parties ~ One more intriguing thing about the manual change method. I first tried it in an English only, three-column course. Now I am trying it in a three-column Mandarin/English/pinyin course. The same logic is being used with Mandarin and pinyin characters (adding and removing an @ symbol). It works with those languages as well. Hopefully it works with any language. The “phantoms” are gone from all my re-testing on the words that have been changed to this point. :smiley:


(DW7) #88

@SetFree

@pdao I made all my manual changes in the various levels of the course, not the respective database(s).

Me too - but I just deleted and later re-entered the correct answer. I did not do your “@” routine.

I don’t save and continue, I just do “Preview” (a save I think) then edit the level again. Seems to work and is quicker as it keeps me in the level I am working on.

Incidentally I see all your (@setfree) courses are private and not public yet.


(pdao) #89

@DW7 ~ I hope all is well with you. Last time I looked I had 41 public courses on my profile teaching page. Many more are private either by choice (for my own learning; for my tutor students; or are still just works in progress at the moment, but will go public when completed).

Like you, I tried just deleting and re-entering, but the “phantoms” would re-appear somewhere down the line. You won’t see them in Preview mode, but you will in test mode - somewhere down the line, since they are attached numerous times (not just once). The “@ routine” (your term) was the only way I have tried that really works. If something else does, then more power to you. Whatever it takes to vanquish these buggers once and for all.

And I corrected my typing error from my first post. I made my changes at the Database level, not the course levels.


(DW7) #90

Sorry for the confusion. I was trying to reply to @setfree but I wanted to quote you.

Yes one does have to delete the entry every time the wrong answer is presented as a dummy alternative (ie nothing to do with the corrected entry) and this can be many times. So I deleted the complete field, previewed and then when I returned, I re-entered it.

Oh that we could have a “regenerate alternative answers” button @Joshua.

Yes I’m well thank! (Pleased I finally reached MemBassador.)


(Set Free) #91

Thank you both again for the clarification.

@DW7 this is my first attempt at making a course (still in the incomplete stage, and I’m very much still a ‘rookie’). I am not sure I could make the course public when it is finished. I am using Rocket Languages French course to learn French, but find the structured repetition of Memrise works incredibly well with my recall. So, I am slowly downloading all the audio segments (words and phrases) and using them to build a course to help me better remember what I learn.


(t-hero) #92

I ran the script and still phantom answers persist. This bug really needs a proper fix. Don’t think I can justify continuing to pay for memrise.


(pdao) #93

@t-hero ~ if the script does not work for you, and you don’t want to try eradicating the phantoms manually as I did, there is one more option. If your course is not public with other users already taking it (or if it is private and if you are not too invested in it yourself for learning). Assuming you have all your words in some kind of Excel worksheet or Google doc, it is possible to create a new database, and just re-upload the correct words in the correct level(s).

The phantom answers are database specific, so if you create a new database, and delete the old one, the phantoms will no longer be present. (The one caveat however is that using a new database means you will lose any learning in the course you achieved with the old database. So you have to decide if it is “worth it” in your case. You won’t lose accumulated points however.)

I do agree though (as do many other users, I’m sure ) that this issue “really needs a proper fix”. When and how that will come from Memrise is unknown. Hopefully sometime soon.


(t-hero) #94

I sent memrise an email to ask them if they have any intention of fixing the bug. This is the response I got:

We are aware of this bug (and of-course hope to have it fixed) but due to the size of our team, capability’s and other on-going projects with the Memrise platform, we have to prioritise certain tasks. We can assure you however this bug is on our to-do list.


I correct some word but the "old word" still is showed as proposal
(Neoncube) #95

Hey guys! I ended up writing a script that’s supposed to attempt to remove phantom entries from a course.

Feel free to give it a shot. It’s here.

Thank you to everyone in this thread who took the time to track down what was causing the issue :slight_smile:


(Overlord Hydroptère) #96

i’ve been trying to get over this items for days now:
Spanish le interesó la cosa ayer
English
The thing interested him/her yesterday, The thing interested you (formal) yesterday
also: te interesó la cosa ayer
English
The thing interested you (informal) yesterday

but I cannot (it is not my course): there are two identical entries in the database, one a phantom. Maybe ziggy should resolve this very old bug???

(https://www.memrise.com/course/27022/latam-indicative-present-preterite/181/garden/learn/#ts=1501583450)


(DW7) #97

Sadly I found that one has to note every time the wrong dummy answer appears on many different questions) and go through that tedious procedure.

I agree entirely that there ought to be a “Reset test questions” button, so we would know that after a major overhaul - which I’m sure has happened on the official courses.

Cc @Joshua


(DW7) #98

I think (I hope) I have had a flash of inspiration that might be easier to apply than the laborious task when many items in a “column” are affected, such as when one does a major update.

Initially on a new course I had created, I wondered if it would be quicker to start again and then delete the first course, as no one had found the course.

But then I thought of a similar solution that wasn’t so drastic.

I created a new column, cut each item from the affected column (now amended) and pasted it to the new column. Finally I had to delete the old column and adjust the testing to show the new column.

I appreciate that in a course of a 1000 entries this would not be desirable and another method would be necessary!

However I do still think a “RESET” dummy answer (ie REGENERATE dummy answers) would be the best thing for all creators and curators of abandoned courses.

Cc @pdao & @Maxine_Downunder @Joshua


(Lurajane) #99

@Hydroptere - I don’t understand what you are trying to say about those two different entries. I’ve cycled through quite a few review cycles on that course, and haven’t encountered any phantoms. The two items you mentioned are, well, two distinct items, yes?


(Overlord Hydroptère) #100

the fact you did not encounter them it does not mean they don’t exist, is a huge course. As I am over that level, I will not meet those entries, cannot please you. As about thge general problem, it is still present, after all these years (I have it in all my courses in which I edited the entries over the years). I have it in many courses in which (other than me) creators edited/corrected entries, or added some new info.


(Lurajane) #101

Take a screen shot if so-called phantom entries appear again in the course.

What you posted above are two legitimate items in the course that are very similar.


(Overlord Hydroptère) #102

the strangest is when deleted audio files still come up…

i did not see a team member in here for a while… wonder if they still mantain the fora…