Deleted/old answers still appearing in tests


(Windmonk) #1

So, I’m creating a course with audio and text. As I do it, I keep changing and upgrading stuff. One of the things I’ve done is replace some of the question/answers with new ones that have better audio quality, or different text. The problem is, when testing the course, old audios and answers still appear, which I’ve deleted. It’s annoying because they show up as options to choose in tests, and they’re always wrong and outdated.

It seems this has been a problem for a long time. Some more info was discussed here: http://www.memrise.com/thread/1762704/

This is my course: http://www.memrise.com/course/1115494/ear-training-chords-progressions/


How do I get rid of these long answers that are making my course annoying/unuseable?
Multiple Choice - Old items before correction showing up
Deleted definitions still appearing as answers
2 similar / same definition for one word
Deleted words showing up in lessons/reviews
Answers that are identical pop up; 50/50 chance marked wrong
[Course Forum] American Sign Language by Diana.S
Memrise website and apps are down [ Edit: Fixed! ] (and Closed )
The attribute data shown in multiple-choice item
[Course Forum] HSK Level 6 by DrewSSP
Words not updated to match the course list
Databases and weird multible choices
Quick and Effective Way To Remove Phantom Entries
Phantom word prohibits me from learning new vocabulary
[Userscript] Attempt to Eliminate Phantom Entries
Deleted definitions still appearing as answers
(pdao) #2

@windmonk ~ thanks for resurrecting this issue. On my end, I am still experiencing this issue in several of my TOCFL courses, and now it is both on the iOS app and website versions (probably Android as well, but I don’t go there very often). I gave up worrying about it. Hopefully it will be resolved some day. But in light of all the other things on Memrise staff’s plate, I doubt it. It’s probably very low priority in their eyes. It sure would be nice though if we could just be told where these “phantoms” occur, because none of us can find them in our respective databases, and yet they continue to appear at testing times with no rhyme or reason.


[Userscript] Attempt to Eliminate Phantom Entries
(Ultra-Sadist Delinquent) #3

Also having the problem.


(Charles Applin35) #4

My course is experiencing this problem as well. It’s an issue as it’s pulling up a possible correct answer to the question but will be marked as wrong as it’s a deleted segment.


(Teolives) #5

Same problem here, I’ve reported the issue several times but I’ve had no reply so far…


(Deagger) #6

Same here lol


(Drew) #7

I’m experiencing this frustrations right now. I noticed something interesting…

You can pull up the info for just about any word in Memrise by changing the ID at the end of this link http://www.memrise.com/api/thing/get/?thing_id=100011876. I’ve used this information to create a few scripts throughout the past few months and I can see that each word has a list of (what I think are) the possible options that you might be offered when the word comes up in a review session. I’m wondering if I can use that to fix this problem somehow.

Just a thought…


(Drew) #8

Expanding on this further, I don’t know of a single user interaction in which this information might be manipulated so I can’t see an example of how Memrise might want me to do so. I guess that we wouldn’t have this issue if there was such a user interaction. Either way, if somebody knows something that might shed more light on this, I might be able to program something to fix this issue.


(pdao) #9

This is intriguing. How does one go about finding out what id # corresponds to what word/item in Memrise ?


(Drew) #10

Memrise does start getting interesting when you start looking at it from the inside.

I get the ID with Chrome. Go to your database page in a course and right click a word and click Inspect Element. This will show you the source code of your database page. Scroll up and down a bit and you will see “data-thing-id=” followed by a 9 digit number. That will appear many times. Those nine-digit numbers are the ID numbers for each item.

This is just one way to get this information.


(pdao) #11

@DrewSSP ~ Thanks for the info. I found the sample id’s I was interested in. There is a lot of info on the screen, but unfortunately I was hoping that the “phantom” information would also be included among all the other relevant data, but it wasn’t. I guess it has really hidden itself well ! The search continues for where it actually resides… Have a good day !


(Drew) #12

I would be surprised if it wasn’t there. Maybe I’m wrong. Would you mind showing me a word in which you saw one of these deleted answers appear?


(pdao) #13

I ran this thing a couple of times this morning on a couple of different words and it looked like each time it pulled up the word in question and then the 7 other options that were offered when it last appeared as one of eight choices in a multiple choice review for the course in question. (That is assuming I was reading it correctly).

I see “phantom” entries in a lot of courses, but I am trying to zero in on just one course in particular since I know it is small (only 33 items) whereas all my others are much larger; and it has one very obvious “phantom” entry that I see quite frequently, and I know for sure it is not in the database.

The course in question is a simple image-based one found here: http://www.memrise.com/course/1147950/washington-dc-monuments-memorials the database number is 2116292 and the word that exists in the database is on page 2 is “Watergate Complex”, but the “phantom” entry that shows up is “Watergate Apartments”. (I changed it after I uploaded into Memrise from Excel once I realized it was incorrect). The “phantom” entry is never tested on, it just shows up as an offering for other images in the multiple choice questions at review time.

I was hoping if I (or anyone) could figure out where just one simple entry resides, then the logic for finding that would hopefully reveal the logic of where the other “phantoms” reside in other courses (which have many more examples than just one). Maybe its a pipe dream, but one can always hope. I added you as contributor on this course, in case you have a desire to look under the hood. Many thanks for any insight you can offer.


(Drew) #14

Can you please do me a favour and try something for me?

Find a word in which a phantom answer appears during one of your sessions. Do not answer it. Instead, quit your session and find the word in the database for the course. Add a letter to every column that has text in it, refresh the page, then delete that same letter in every column so that it’s back to normal again. Start a new session and answer questions until the same word appears again. Does it have the phantom answer still? If not, we might have found a solution that I can use to create a script.

If it worked the first time, try again the second time.


(pdao) #15

Okay, I think I get the gist of what you are suggesting and will try this tomorrow. It’s getting late here tonight, and I have to focus on making dinner and such. Thanks for the insight. Hopefully I will have something to share with you soon. Have a good evening !


(Drew) #16

Great! Please let me know if this fixes the problem for you. If it does, I have already created a script that will fix the problem and I would be willing to apply it to your courses if you are willing to give me editor permissions.

I already applied it to my HSK Level 6 course and it SEEMS to have fixed the problem. Of course, it’s one of those issues that is harder to prove as being fixed but I’m optimistic.


(pdao) #17

@DrewSSP ~ I did a lot of testing on this, and I basically came to a few conclusions:

Phantom entries are created when entries are deleted from the database AFTER they have already been tested on (but I knew that already from when I first encountered them a long, long time ago). It was very easy to create them during my testing.

They are not created when columns in a database entry are changed in some fashion, even if they have already been tested on.

They appear in both the web version and the app version (at least the iOS app, as I didn’t verify the Android version).

They appear regardless of the number of columns in a database (I tried between 2 and 6, and even a test case using an image-based column).

The key seems to be WHEN the database row was deleted. BEFORE testing, obviously nothing in history to worry about. AFTER testing, then there is something that resides somewhere in Memrise that isn’t visually obvious in the course database(s). That has always been the central question. Where do they reside since no one apparently can see them, yet the testing process pulls them up for display as possible responses, (albeit incorrect ones).

Your logic of appending/deleting a letter in each column of a database item did not work in my case. All it seemed to do was create more phantoms with the appended letter on the end of each item. (More than likely I did something wrong when I tried to follow your instructions).

I’m not sure if others (possibly yourself) are claiming that phantom entries are being tested on directly, if so, that is different from what I am seeing, or referring to. In my situation, I am only seeing them as possible choices for another item that is being tested on. Choosing the phantom would obviously be incorrect, but since it doesn’t seem to reside in the database, my issue has always been, why is it even an option as a response for another item. Why didn’t the database row deletion entirely remove it ? Is there a secondary place where deleted entries reside ?

I’m not sure if any of this makes sense to you, or anyone else, but basically, I am back where I was originally. I see things that shouldn’t appear, but can’t delete them. Others do too. I guess only Memrise can shed some light on this issue, or maybe your logic does things that I don’t quite understand. I’m going to just let this issue wallow for a while. I need to focus on other things. I thank you though for your time and effort with this issue. I hope your logic works for others.


(Ultra-Sadist Delinquent) #18

I haven’t deleted entries from my courses, I have only, rarely, changed the tested on column after clicking “edit” in the reviewing screen. I seem to remember in some cases being presented with the old tested on column alongside the new one after the edit. Maybe deleting entries is a good way to create ghost entries but editing the columns also sometimes works? Or I am misremembering things?


(pdao) #19

@Arete_Hime ~ that is entirely possible. I was merely looking at entries from a database standpoint of whether or not they were impacted by deletions or changes to items. I didn’t bother to look at the actual testing process. That’s a whole other animal to consider.


(Drew) #20

I’m still not convinced about your problem being different from mine. I’ll offer one more time to fix the problem on your behalf with my script. Unlike a user, my script does not need to add a letter and then take it off. It does it all in one go and just tells memrise “hey, please take a look at this word again”. It cannot create new entries with added characters like you saw because nothing ever actually changes when I run it.