Deck selection glitch: On selecting next deck to study previously studied deck keeps reappearing

Sorry, it is really difficult to adequately describe what is happening, but it’s been going on for a bit over a week now. It’s pretty annoying. This is on iOS (iPhone 8) version 13.6, v3.2.1.23345.

Basically, I finish studying one deck in my list (e.g. - JLPT N3) and exit this deck, tap another deck (e.g. - JLPT N2) to start reviewing/learning that one. However, unlike normal I am instead directed to the previous deck’s page (e.g. - instead of going to JLPT N2 deck which I tapped/selected, I am sent back to the JLPT N3 deck’s homepage). Often I don’t notice until I tap the review/learn new words button and I realise I’m still on the deck I was previously studying. The deck that I tried to enter now appears second on the list. Sometimes I have to enter/exit the deck several times before I finally get directed to the deck I want to study’s homepage. This is most noticeable across languages (e.g. - JLPT N3 to Mongolian 1), however that might just be a coincidence. It doesn’t happen every single time, perhaps half the time I can change between decks without issue.

Sorry, as I said, describing exactly what is happening is very difficult to articulate, but if other people are having a similar issue they may be able to explain it better.

Thank you for your time.

1 Like

Ah, so it’s showing up on iOS as well. I’ve reported the bug in my Android bug list, the discussion starts with this post here:

The Memrise team is currently trying to resolve the issue. FWIW, as of today, the right course was activated when iterating over an official Memrise course (i. e. tapping the link to a subsequent course at the bottom of a course, so moving from i. e. Russian 1 to Russian 2).
I still had to select some courses 2-3 times this morning from the course list though, so it’s not completely resolved (on Android). Don’t know about iOS, but I suppose you’ll see it fixed soon.

1 Like

Hi @LilianaBrayf0,

Thanks for reporting this.

We’ve created a ticket for this issue - our developers will be investigating further.

I’ll update this thread once I have any updates.

Thanks for your patience.


Thank you very much for looking into this issue.

I’ve been suffering this for quite some time. Just tried deleting and reinstalling app but same problem when trying to switch between my three official courses, Spanish 1, Spanish 2 and Polish 1. It’s very hit-and-miss whether it will actually select the course I tap on.

Current app version iOS

I have reported this very same problem more than a week ago. I don’t understand why so many problems occur with the app, why the testing doesn’t uncover them and why it take so long to fix. I have other problems as well.

Hi all, thanks for your reports. I can assure you that the ticket has been raised to our devs again. It will be looked at asap and I’ll make sure to update this thread once I have more news.

Thanks for your patience!


Thank you for your ongoing efforts. Just letting you know, it’s still happening.

Hi, just posting again to let you know this is still happening.

Hi, thanks for your message. This is being worked on and a fix will be released soon. Unfortunately I don’t have any timeframe yet, but I’ll be notified when the ticket is updated, so I’ll make sure to post any news here. :slight_smile:

Thanks for your patience.


i’m experiencing the same issues, often I can’t change courses on iPad mini IOS version 12.4.8. it just stays on the original course.

10 days later and the bug is still there. What are you doing?

This has been around for five (!) releases now (3.2.2 to current 3.2.6). I reported it long time ago and still no fixing. In our company such a P1 regresssion would result in no release of SW until it is released.

I suspect this all started when they added those odd background layers with more UI code – and most of those entries are totally unneeded and makes the UI so cluttered. But if they just fixed this bug before they release another 3.2.7 like nothing would have happened…

1 Like

Hi. This is still an issue. It is very, very disruptive. Sometimes I spend two to three minutes trying to change between decks. I restart my app two or three times, because that seems to help. However not every time.

Yes, it’s a kind of accumulated hit test issue, you start the app and it’s fine and then over time it gets worse. Might be a rounding issue or using integers for hit calculations and not re-setting the offset values over time. Or then the new background layer refresh (which is also ugly looking, check each time you select a course you get this flash) causes wrong hit test values calculated.

It should be easy to regress test, go back before 3.2.3 and find out what check-in causes the issue. Then easy to fix. Unless the code and architecture is so convoluted and full of dependencies so one fix breaks something else.

I’m happy to report that this bug was now fixed in 3.2.7 released yesterday, I’ve been stress-testing selection of courses from the list view and they all open up without issues, first-row or any row in the list. Thanks!


How many courses are you learning? Perhaps if you have a small number of courses, the issue disappeared on your device.

I have v. (installed 2 days ago), on iOS 14.0.1, and both iPhone and iPad still have the same issues - I have to click lots of times to be able to switch from one course to another.

Best regards,

20 courses. Also try to kill the running Memrise - home double-tap, swipe up the Memrise mini-window. That will restart Memrise without the need to reboot the whole device.

This is a iPhone SE 2020 edition running 13.7, will take a month before I upgrade to 14 to get a more stable 14 OS.


I tried your suggestion (killing the running app) but it didn’t resolve the issue, not even temporarily - the courses don’t switch easily.
I’ll wait for another update of the app.

Best regards,

What device is this and what iOS version?