Courses will not download

Hi there, can I kindly ask for a couple of examples of courses you are trying to download? We monitor failure rates and are not seeing any spike in this problem, but perhaps there is individual problems with some courses or something we are not seeing.

Can I also ask if you are on the latest version of the app that you can download from google play?

Kindest,
Jesus

5 Likes

Thanks for your quick reply, here are the courses I have been trying to download:

  1. https://decks.memrise.com/course/781112/advanced-colloquial-german-c1-c2/
  2. https://decks.memrise.com/course/116402/german-words-from-tv-shows-news-articles-etc/

I think I am on the latest version on Android: 2.94_17117_memrise .

Thank you for your answer. I have been trying to download my course
https://www.memrise.com/course/1381238/spojky/

I have added some new words to this course.
I have latest version on Android: 2.94_17117_memrise

If you changed anything within the course, you’ll need to log off and log back on to see the changes within the Android app. This is another problem but it hasn’t anything to do with the download problem!

Why I have to log out? It read me this: If you log out any courses you have downloaded for offline use will be removed from your device.
I won’t download all of my courses again.

Don’t blame the messenger! :slight_smile:

That’s just the way it works - changes aren’t propagated to the app unless you log off and log back on. See #2 of my bug-list.
And yes, if you log off, you loose all downloaded content, meaning you’ll have to once again download everything.

Hi there!

so the infrastructure is working correctly and we can see our failure rates being consistently low. I have had a look at the courses that you are referring to to understand where the problem lies and I can see that it is due to (at least in one in particular) to an asset being corrupt.

For course https://memrise.com/course/116402/german-words-from-tv-shows-news-articles-etc/
one of the three audios for the word riechen in level 4 is corrupt. If you could remove that audio and reupload it, it should solve the problem.

I could see that the other courses have also got some similar problems but I will get back to you in the following days with a list so that we can sort it out for you.

I hope this helps!
Jesus

5 Likes

I have logged out and logged in. I lost my course for offline use. I cannot download any course.

I cannot download this course:


https://www.memrise.com/course/1381238/spojky/
https://www.memrise.com/course/1713947/pel-mel-anglickych-slovicek-frazi-a-vet-viii/


https://www.memrise.com/course/1341736/pel-mel-anglickych-slovicek-frazi-a-vet-ii/
https://www.memrise.com/course/1406949/pel-mel-anglickych-slovicek-frazi-a-vet-iv/

https://www.memrise.com/course/1802324/collocations-2/



https://www.memrise.com/course/1382913/english-idioms-and-phrases/
https://www.memrise.com/course/271871/english-dependent-prepositions/

I will add more courses.

Hi,

as I mentioned in the other post, the only course I have looked at, has got a problem with an asset that is corrupt. that is not a Memrise infrastructure problem but is something that the course creator has got wrong with that asset. as simple as reuploading and it will work.

I suspect the courses you are posting here have got the same problem. If you try to download an official course (or any of the thousands of great user generated courses that are maintained) you will see how they download just fine. I will be inspecting them and letting the course creators know about the problems in their courses.

I am going to kindly request you to use respectful language from now on. I have edited that last message to reflect that as we will not tolerate bad language or abuse here.

Thanks,
Jesus

5 Likes

Where I will check my course so that they would be correct. I made a lot of my courses. I had over 30 offline courses on my tablet. I downloaded all of them. Now I can’t download them. Where is the error? Is it my fault or Memrise fault? As I see it that it is a memrise fault.

Thanks for the reply as well as investigating the issue. I see that I could re-upload the courses I’d love to study and manage it myself, but there are concerns:

  1. I might lose my progress on that course
  2. Not giving a proper credit (what is the course’s license, btw :slight_smile: ) to the course’s original author, though maybe I could set it as unlisted, however,
  3. Other users cannot create mems on top of the re-uploaded, unlisted courses.

Notifying the maintainer might be the best way. I checked the German community for the course, yet there is no maintainer set for this course here: https://decks.memrise.com/course/781112/advanced-colloquial-german-c1-c2/. Unsure how I could contact the author, since (s)he seems to have no Memrise Community Page: https://community.memrise.com/u/xmrsexydragonslayerx6969.

With that being said, is there any way to ignore corrupted parts of the course and proceed with the download? I tried a third party, Anki-style app that has import & download feature from Memrise decks here https://play.google.com/store/apps/details?id=com.MemorionSoft.MemorionV2&hl=en and the app manage to download it for offline use. I am somewhat optimistic that this can be solved.

And thanks for your works at Memrise. Community-based courses might be varied in quality, yet for users like me, it is one of the best features of memrise compared to its competitors.

I suggest you apply to become a contributor to the course. Read more about this here:

1 Like

Hey! So as Olaf suggested we can definitely grant contributor access to courses that are abandoned. Please refer to that and ask in that part of the forum, we will get it sorted.

We are looking at ways to improve further offline mode and looking at the rate corrupted assets fail is on our radar. We might ignore them fully or ignore IF there is a low percentage. That being said, the quality of a course depends highly on its assets so we always recommend keeping them up and healthy.

We will let you know how we progress on this.

Kindest,
Jesus

5 Likes

Done! I have requested a contributor access to the relevant forum ([Course Forum] Advanced Colloquial German (C1-C2) by xmrsexydragonslayerx6969). Thanks for the assistance!

1 Like

I am having the same issue, but intermittently. Some courses will download just fine, others usually fine, some virtually never (though they did download before). They are usually relatively small courses, some without even images or audio.

@JBorrego: could you have a look at my course that doesn’t download?

BTW: I see that you found some ‘corrupt assests’ with the courses you looked at. Do you think that Memrise would be able to find why those corruptions actually come into existence and fix the root course? Thanks anyway.

Actually, that is not what I experience. When I remove the download of course, the course will ‘refresh’ itself (sometimes after a few seconds, sometimes after many tries). Downloaded courses won’t refresh. But anyway, I see it as a bug, too.

That’s quite interesting. I just went ahead and changed something in a course and then downloaded it. The download didn’t work (it was stuck at 0% for some ten minutes), but when I cancelled the download, the changes were updated in the course. That’s actually a nice workaround, cheers!

I can see the behaviour on that course is different. I am not sure why yet.

We will be working on allowing courses with a % of corrupt assets to be downloaded. We will be looking at this after Christmas and see if we can improve it quickly. That way courses will require less maintenance too.

6 Likes

I have some problem:


Thank you! I am looking forward to it.
Is there a way though, that prevents the corruptions to happen? And would there be a way to correct the corruptions? That seems more stable long term. Anyway, thanks and hopefully we’ll see the fix soon.