Courses not loading / extrememly laggy if app loads


(Ravyre) #1

For the past couple of days I’ve been having a lot of trouble using the Memrise app and I believe it is caused by the most recent update.

I simply cannot get past the loading screen. If the app does load then it is extremely slow and laggy; typically my phone is popup a “Memrise is not responding” message and ask if I want to close the app or wait.

I’ve tried rebooting my phone. I’ve also uninstalled and reinstalled the app. I’ve even cleared some space on my phone. What I find particularly odd is that my partner doesn’t have this issue at all. He can easily load up Memrise and use the app.

I am using Android 8.1.0 with Memrise version 2.94_7530
My partner is using Android 8.0.0 with Memrise version 2.94_7530


Learned words count help
(Montgomerry) #2

Second that. Exactly what I’m up against at the moment.
For the past couple of days, also after Android 8.1.0 upgrade I’m unable to use Memrise app due to extreme slowness and lagginess.


(Ravyre) #3

Oh, I’m so glad that it’s not just me. :smile:
I do hope that the Memrise team are able to find out what is causing the issue so that they can release a patch soon~ :slightly_smiling_face:


(Tomek Wilicki8f) #4

Same here. Seems like only long courses (more than 2-3 thousands words) are affected.


(Zteps1) #5

Same extreme slowdown on long courses. Android 6.0 and app version 2.94_7636 (problem started around previous update on november 10). Reinstalling or clearing cache doesn’t work.


(Memrise Matty) #6

@Ravyre @montgomerry @tomek.wilicki8f @zteps1

Thanks for this information. Can you advise what course this happens on? i.e. What courses are you trying to load when the app slows-down/lags/crashes/freezes ? (please provide the names of the course) :slight_smile:


(Montgomerry) #7

Checked that with my courses and it stands true. I use my own courses, the one affected is a big one, >11k words and some 600 levels. but that size and length didnt matter up until recently as described. when I manage to switch to another course that has a mere 120 words, app starts to be responsive again.
I’m also on 2.94_7636.


(Sp4mblob) #8

hi guys.
I can second the above feelings. I’m using memrise on android 7 and for about a week, long courses have been slow (course with 1800), quite slow (2500 words) to painfully slow (5000 words). everything is slow about this course, even just switching to and from those course or even just bringing the exercise selector.
this kind of behaviour only started in November. I’m using the latest memrise version (although today was an update, I haven’t checked yet if things have improved)


(Zteps1) #9

For me it’s
The Ultimate Kanji Course (8514 words)
+ Core Japanese • Vocabulary (6000 words)

Thanks!


(Ravyre) #10

For me it is also the The Ultimate Kanji Course


(Memrise Matty) #11

Many thanks - This issue seems to be isolated only to long courses. We were able reproduce the performance issues by using the course Ultimate Kanji.

Our developers are investigating and we hope to provide a solution as soon as possible.


(Memrise Matty) #12

Hi - We should have an update for Performance issue and Download errors on Monday.

Please note, quitting courses with thousands of items should solve the error in the mean-time.


Learned words count help
(Raija86) #13

The same happens with my Finnish course: "Finnish Grammar/10,000 sentences.


(Montgomerry) #14

Just got the app updated. Looks OK. the app performance got back to normal. Thanks.


(Zteps1) #15

Can confirm the problem solved in a recent update. Thanks for a quick patch.