Course not updating after changes are made

In this course I’ve created ( I don’t seem to be able to correct the various errors I encounter while doing it, i.e. after correcting an error in the database, the previous incorrect version still appear in the reviewing sessions. Any clues?

It seems to me that you started a review session, found an error, went on to change it in the database, continued with the session and noticed that you change had not taken effect. Is that the case? When starting a review session, you browser downloads all the data it needs for that session up front, which means that you will not see any changes in sessions in progress.

Hello nphx and thanks for the reply.
No, that’s not the case. Changes do not take place at all, even with a new reviewing session.

As you can see from the above image #2 is the correct answer (no spaces after the plus sign) but answer #7 is still there (yet it is nowhere to be found in the database)

I typically find that the changes are applied after logging out and back in, but not always. Sometimes it just takes a few days for the change to be applied.

Hi there, I’ve logged off and on and waited several days but the “ghost” answers are still there. :confused:

But oddly enough the other day I made a correction and that was taken, yet others are still wrong (and not in the db)

But does it recognize the correct answer as correct? That’s more what I was referring to.

Sometimes I have ghost answers that I deleted months ago that never went away. It doesn’t bother me that much as long as it shows the correct answer when planting recognizes it as correct. One fix I have heard is to change your course from public or unlisted, make it incomplete, and then change it back to public or unlisted. I don’t know if that works or not.

Have you tried changing the status of your course? i.e. published/unfinished etc. on the details edit page.

If not, change the status, press save then change it back to what you want. This seems to trigger an update of the database, but it can take a couple of days to see the effects.

If you haven’t I’d also do a search of your database to make sure there aren’t any odd entries appearing for the items you are having an issue with.

Good luck! It’s an issue that seems to occur regularly …

I did try to change the status a while ago but it didn’t seem to trigger any update. I’m trying again but this time I’ll leave it as “incomplete” for a while.
@cherub721 The correct answer is considered as correct yet as you can see from my previous example (7=right vs 8=not in database) but as it’s only a matter of spaces one could consider #8 correct as well.
@leggi I’m positive these items are not in the db…

Changed from “public” to “unfinished” and back and no luck!

@Joshua here you said you are working on db issues: will this solve the issue with this course as well? I’ve actually noticed there were some words in the db that were missing from the levels yet the “ghost” items as per my previous images are nowhere to be found, yet they still appear in reviewing sessions.

the status change used to work :frowning: eventually, but there have been so many updates and changes to the site.

Are you using the website or the app? I’ve no experience of the app (and keep forgetting it exists) but I’ve read you have to update/re-download it/refresh it or something for changes to show up.

Otherwise, I’d report it as a bug and see what Memrise says…

So, I’ve finally found the source of the problem. By editing the DB directly (not the levels) I’ve managed to erase the entries that were somewhat created during mass import.

@teolives ~ glad that this worked for you. But you should note that while this may have resolved the issue in your particular case, there is still an outstanding database issue where “phantom” entries appear in testing on courses where they DO NOT reside in the database. In essence, there is nothing that a course creator can go in and delete.

This issue was reported in the old forum numerous times, and has also appeared in this new forum. Old issue, just new forums. Many of us would love to see these “phantoms” go away, but it is unlikely this issue will ever be resolved. Glad it worked in your case though.

Well, I was perhaps too hasty in saying this solved the problem… in fact even after deleting all the spurious entries from the DB (the DB itself, not the levels, mind you) the phantom words still appear in reviewing sessions :disappointed: There must be some sort of cache that could be erased, somewhere.

Welcome to the “club” of course creators who also wonder where these “phantoms” reside. Hopefully someday Memrise will clue us all in as to where these items reside since we can’t see them.

I have the same issue about the ghost answers too. I just make the course again and call it version 2.

Have you seen the script that eliminates phantom entries? Read more about it here:

1 Like