Code 500 when attempting to sign in

Yesterday I signed up on Memrise and started learning German. However, after a while the error message with code 500 started to appear whenever I attempt to sign in to the dashboard. I’d highly appreciate some guidance on this issue.
My PC runs on Windows 10 Pro x64 and I am using Brave Browser. The issue remains when I try to log in to Memrise using Microsoft Edge.

The error message is in Swedish.

I’m sorry to hear that.
I can’t see anything immediately wrong with your account and we’re ending work for the day now.
To help us investigate tomorrow can I confirm you’re going to Log in to your account - Memrise, then entering your email and password (or are you using one of the social logins), and it’s then that the error occurs, so you never get to the dashboard?

That is correct. I log in via email and password without using the social media option.
Afterwards, I immediately get the error, thus never getting to the dashboard.

Hi @brodochskadespel

Can you confirm that this is still happening for you? Since we’ve tried this on a windows 10 machine on the same browsers and aren’t running into the issue.


Hi Chris,

It is still happening. When I click on the “log in” button I am immediately redirected to the dashboard page whereupon the error message shows up. I don’t even get the chance to fill in my information.

Hi! I am also having this exact same issue. I have Windows 10, I’m using Firefox and I’ve attempted to log in with my Google account. I registered myself to Memrise yesterday (with my Google account) on my phone and I tried to log into the browser version of Memrise today.

At the time you posted we were having some nice person attempting to attack our service which caused a slowdown for about 5 minutes . Could you please try logging in again, hopefully all will be well

Nope, it’s still not working for me.

Sorry about that, we are working on something for google signin we will be able to deploy in a couple of days, we’re not 100% sure if it will help but it’s our best guess at this time.
In the meantime can you try using a different browser?

The issue remains today.

Have you had any luck with any browser?

My course on Memrise is set on the German course, if that’s of any help.
When attempting to log in to the dashboard, it is trying to access that.