Can't upload images to mems


(Sujiro) #1

Hi, it’s been a while since I can’t upload images to mems.

I was posting in this thread: Mems not saving? and since it was locked, I was advised to open a new one.

Can’t upload neither in Android nor on browser. Nothing happens when I select the picture after I press “upload”, and if I click on “save”, the message “Uh-oh, something went wrong. Click OK to resume your session (CSRF failed.)”.

Can this please be fixed? If this is a problem with my account, please check it out: Username: sujiro (Premium Member).

Thanks.

EDIT: Guys, I found the problem. If you try to create the mem with the picture for the first time while in the exercise, it will work. But if you try to edit a created one in your homepage, it won’t accept pictures.


(Amanda Norrsken) #2

What?!?! They fixed this after it was AWOL for about ten days. I am sorry to hear you are having this problem.

I will try it out myself and report back.

OK, here I am again, having just successfully made this picture mem:

I know the memrise team are trying to keep the file size of pictures smaller or something, to save on storage space, I think. Was it a very large file that you tried to upload?


(Sujiro) #3

Guys, I found the problem. If you try to create the mem with the picture for the first time while in the exercise, it will work. But if you try to edit a created one in your homepage, it won’t accept pictures.

Try it out and report back please.

I usually create mems with text-only when I’m doing the exercise for the first time, and then I add the image with the Edit feature.


(spdl79) #4

I was able to create a Mem using the method you described just fine.

  • I created a text-only Mem
  • I went into my profile/mem page and selected the text-only Mem
  • I edited the mem, added a picture and it saved successfully

Although I can’t of course guarantee you’re experiencing some other sort of bug, Amanda is right in that files which are too large won’t upload properly. I can’t remember if it’s 5mb or 10mb, but anything larger than that simply won’t upload. In cases like that, I just open the image in paint, shrink it by 50%, save, and try again. That usually does the trick. Perhaps give that a go and/or try a few different images, as there are also a few obscure image types which Memrise doesn’t like. Good luck and let us know how you get on.


(Sujiro) #5

I still have the same problem as described.

Here are some screenshots of the problem. The filesize in this example is very small (58 KB) and while I tried to upload it during a Review session in the lesson, it worked just fine. Can’t add images with the Edit feature in my homepage though.

Same problem both on phone and PC. Tried different browsers.

This is making me sad.

<img

Here, in the lesson, worked just fine in Preview Mode:

The image I used (58 KB).


(spdl79) #6

Sorry to hear you’re having problems. Looks like something @Joshua or one of the Memrise staff might have to look into; I’m out of suggestions.


(Joshua) #7

Did you create the mem from your Android device?


(Sujiro) #8

Did you create the mem from your Android device?

Yes, I mostly use the app. If I could upload images directly from the app, the browser would be pointless to be honest.

Galaxy S7, Android 7.0.


(Joshua) #9

Your problem might be related to another thread.

Please have a look at this thread.


(Insanity54) #10

I have this problem also. I’m on OSX using Firefox. I have never used the app. I can’t upload mem images via Firefox, I have to switch to Chromium to do that. However, once the image is uploaded, I can edit the mem and text placement over the image using Firefox.


(Siglinde) #11

Old topic but still same problem - occurring on Chrome too. Picture upload in mems shows no reaction at all. However text mems can be saved.
I tried png and jpg, small size (850x281, 42KB), with and without file extension in the name…


(only an user) #12

I did a test with Chrome, and the figure uploaded normally. I used a jpg figure of 500x327 153K in the first test, and another of 1024x768 233k in the second test.

Example - test 1:

Example - test 2:


(Siglinde) #13

Thank you for testing. So it’s not because of size, format or weight… Well, I tried again, even from another account, still same pb.


(only an user) #14

Now that we’ve tested that the problem is not Memrise with Chrome (web version), it’s likely to be local. There may be a problem with your browser configuration or a Chrome extension that you have installed on your computer.


(Siglinde) #16

Works again from firefox. :slight_smile:


(only an user) #17

Glad you found an alternative :slight_smile: