Can't download courses properly!

Can’t download courses properly since the last app update! Tried restarting phone (I use a Note 3), reconnecting both mobile internet and Wi-Fi, tried logging in and out, reinstalling app, etc. multiple times. Very disappointed.

Any input would be highly appreciated. Thanks.

Moved to Android Bugs.

Hi Copydemon13,
Many thanks for letting us know.
We’re aware of an issue with downloading larger courses. Our developers have fixed it in the next version which is currently still in Beta. It will be released for production by next Wednesday.
Apologies for the annoyance in the meantime.
Best wiehes,

@Lien ~ greetings to you. Will the release next week also resolve the issue of non-Pro users not being able to download courses (however small or large they are) on the Android app, or is the plan to still keep that functionality for Pro users only ? Many thanks.

1 Like

I too would like to know the answer to that question! :grin:

Hi Pdao, the offline mode will remain a Pro feature.

@Lien ~ I hope all is well with you. Thank you for the response. We now finally have confirmation and closure on this issue. Have a good day.

1 Like

Hello @Lien, is the fix now available to all users? I have downloaded a new version today (with a slightly changed desing too, the download button is now visible in the corner of the planet screen) and my courses still refuse to download.

Unfortunately, the application glitched for me yesterday and forgot all data it had, so I had to log in again and also the downloaded courses disappeared. I’m trying to re-download them now, managed to download one smaller one, but the bigger ones never finish. So it looks like the fix is not in place yet or it doesn’t work.

Oh dear… @Joshua Can we please further investigate asap?

1 Like

Update: I tried again yesterday evening and managed to download two of the courses I want. Each took between half an hour and an hour, though - although I was on good wi-fi. The third course kept failing - I tried several times and it always ended with a message about a connection error and suggested I check my wi-fi.

Now I am also worried about the amount of data the applications stores. Before all this happened, Memrise used up about 500 megabytes of data on my phone. That’s a lot, but I can live with it if the courses really need it. After the glitch, when the application “forgot” everything, the data was still stored there, so I cleared all application data before trying to re-download all the courses.

And now, after many attempts and with less courses than I had before, the app takes up over 600 megabytes. It looks as though the failed attempts are still stored there somewhere.

How big are the courses usually? What can I do to get rid of the unnecessary data? I don’t feel like trying all over again until the downloads run smoothly.

And right now I’m downloading an update to the app which says that course download has been fixed. Can I trust it? :slight_smile:

Edit: No, tried two times and the stubborn one still doesn’t download.

In order to investigate your issue further, we need to know the make and model of the device you we’re using when the problem happened, and also what android version you’re using. Here you have a quick guide on how to find that out.

It would also be very helpful if you can provide us with the course name so we can further check if there is any problem with the content.

I’m on Samsung S4 Mini, Android 4.3.1.

The stubborn course is
(Could the pictures make it too big? But I had been able to download it before.)

Sadly we don’t have an Samsung S4 Mini, so I used two different phones instead. I successfully downloaded that course and a bunch of other random courses.

Samsung S3 Mini, Android 4.2.2

Nexus LG 5, Android 4.4.4

I have the same downloading problem. My phone is Motorola Moto X 1st gen. Android version 5.1. I have tried to uninstall the app, but it still doesn’t help.

Just for the protocol:
Yesterday I had the same problem: I couldn’t download any course to the app. It seemed that the app tried to download the course - the download icon was animated. But in the last stage of the download, when the download icon gets completely green, a system notification should a network error (seems to be a system notification of memrise, not of the system itself - especially as a network connection was definitely available).

I tried to log-off and log-on, but it didn’t help. And I already have / had the current version of the app.

While I wrote this I tried it again and it worked perfectly, with own courses as well as others.

My system: Samsung S3 (GT-I9300) running on Android 5.0.1.

I also have a problem with download! When clicking download button the app seems to starh download. But in notification it is written “Gathering information”. And it’s been for a couple of hour like that already.

I am using Nexus 7, Android version 6/0/1.
Trying to download French level2

Same problem here. Tried installing and uninstalling, log in and log out several times.
Still doesn’t work.

I am using Samsung Galaxy S7, Android 7.0.

Same here. Cannot download anything. (Android 5.0.1)

Same problem here. Tried installing and uninstalling, log in and log out several times.
Still doesn’t work. These are the 3 courses that i need to download.

1.Ultimate Kanji Course
2.Jlpt N2 Vocabulary…
3.Soumatome JLPT N3

I am using Asus Zenfone 3 Max 5.5, Android 6.0.1
Please reply ASAP, i need the offline feature, these is the reason why i get the pro feature of memrise.