Can't download any of my courses on my Android Phone


(Gabriele Cramer Knebel2d) #1

I am having a problem downloading any of my Japanese language courses. Pressing the Download icon brings ‘Downloading …’ for 2 seconds then it disappears and nothing else happens. The only course that did download is a finished Japanese language course.

This is the only course that would download that is a finished course

Android Device: Galaxy S9
OS: Android Version 8.0.0, Samsung Experience version 9.0
Memrise Version: 2.94_7530


(Gabriele Cramer Knebel2d) #2

I did play a little bit more around to see if I can find the problem and started downloading courses that I have not studied and saved for later use. I found out that I can download courses that have less then around 450 words. Any courses larger will not download.

And yes, I did logout and log back in to the apps.

@MemriseMatty can someone please look into this problem.


(Vladimir Pendić) #3

Maybe, next week or week after next. I am so tired of install and reinstall the app, finding some way to learn without frustration. I didn’t see locals for months. The classic review didn’t work properly from summer. With the last update, an app is freezing. I can’t download offline lessons and can’t start a classic review. Maybe, if I’m patient after 10 minutes I get new ten words. Lucky me…
Well…Matty and others. We are paying this service. It is time to be serious and make a decent app. I’m on the verge of nerves.


(Gabriele Cramer Knebel2d) #4

I have the app freeze up so many times since the last update too that I am really getting impatient. When 1 problem finally gets solved there are 3 other problems being introduced.

@MemriseMatty please tell the Memrise programmers to solve the problems. Don’t introduce new features. PLEASE get the problems we are having solved first.
I am paying for the services but coming close to cancelling if this keeps going.


(Vladimir Pendić) #5

Freezing looks like this. It takes so long to catch the footage.


(Mthierst) #6

I can confirm that I have the same problem with the latest version of the app. small courses can be donwloaded, larger ones just cause a network error notification.
Guess which ones I’m looking to work on off-line…
And yes, I was able to work off-line with all of those under the previous version. I guess that’s what I get for updating the version instead of sticking to what works… here goes my final Pro functionality that still provided value!


(Gabriele Cramer Knebel2d) #7

@MemriseMatty, there are 2 problems mentioned here. 1st. is the download problem the 2nd. is the freeze app problem. Can you let us know if the Memrise team is aware of this?


(Mthierst) #8


this is the error message received when trying to download
this is near instant, so its not a time-out
I’ve tried this on multiple networks which work for everything else, so despite the message this is not a network issue


(Memrise Matty) #9

Many thanks - We are aware of these 2 issue.

Offline Mode - We are currently investigating this cause, and will let you know if we are able to implement a solution that improves the download function / reverts it back to it’s original performance (developers are currently investigating).

App Performance Issues (i.e. Freezing) - We have been unable to reproduce these issues on our end. We will continue to investigate.


(Tomek Wilicki8f) #10

try longer courses, more than 4000 words.

Short ones are working OK.


(Mthierst) #11

just to quickly update here - the update which came down this week does not fix the downloading issue for me.
at the moment it looks like it works for small courses, but anything approach 1000 entries does not work, regardless of connection. And some of my courses are around 2000 entries, and cause substantial revision work which would be good to be able to do off-line

paging @MemriseMatty for visibility (you might already be aware of this of course, apologies in that case!)


(Memrise Matty) #12

Has the latest release solved this issue for anyone else? We have seen a drop in reports regarding offline mode error.

@mthierst What version are you running / what course are you trying this on?


Offline mode
(Mthierst) #13

@MemriseMatty I’m on 2.94_7701_memrise

the following courses don’t work for me (all used to previously)
https://www.memrise.com/course/535745/duolingo-czech-english-vocabulary/
https://www.memrise.com/course/397328/moje-ceske-slova-lekce/

(not sure why two display as links, and one with preview - ?)


(George Margelis0a) #14

Android 9.0, bought a subscription purely for the offline mode, can’t download anything.


(Ismail Ghedamsif3) #15

It said that the course was downloaded but actually none of the words were downloaded.


(Raulfernando91) #16

Same problem. It started with a large arabic course. I thought I didn’t have space so I erased a lot from my phone. Still didn’t work. Erased the app and reinstalled it. I could download small courses only. Erased the app and reinstalled it. I can’t download anything anymore. Any clue? I miss the simpler memrise.


(Gabriele Cramer Knebel2d) #17

I still can’t download any of the language courses over 450 words. And that’s with the latest version 2.94_7701_memrise.


(Jan Michalk23) #18

I cant download even a small courses. I tried to download “Japanese 0” to my phone, but if I am not online it is stuck on either loading screen or “warming the engines” screen. If I log off and log in again, the course is not downloaded. Reinstalling the app did not help either.

I have up to date Memrise app 2.94_7836_memrise
Android 8.1.0
Xiaomi Redmi Note 5


(Gabriele Cramer Knebel2d) #19

Same here. And that’s with the latest version: 2.94.7836_memrise.

@MemriseMatty any words on this problem getting solved soon?


(Memrise Matty) #20

I’ve asked our QA team and Developers to continue investigating these reports, as it seems like the previous fixes have not solved this issue. Unfortunately I do not have a time-line or status update. I will be happy to update you as soon as I hear back.