Apple Japanese Input CHROME Bug: Forced Autofill / Predictive Text

Hi there,

I’ve started up my Japanese Memrise practice again after not using it for a couple of months, but am hitting a very annoying bug when using Chrome and the Apple Japanese input keyboard.

For some reason, whenever I make a mistake on a fill-in-the-blank style question (i.e. not multiple choice, audio etc.), the IME will automatically input the corrected version of that word ON THE NEXT question that comes up.

So for example, I first incorrectly answer with ごしゅうしん instead of ごしゅうじん on one question. Memrise will then make me type in the correct answer as normal. I then go onto the next question. As soon as I press any key, my IME (or Chrome, or Memrise or ??..) will automatically input ごしゅうじん despite that word having no relevance at all to the question being asked.

I don’t have predictive candidates or live conversion selected in my IME preferences and the problem does not seem to occur on other browsers.

Please tell me that this is easily fixable and that I won’t be forced into using Safari / Firefox to revise for my exams… :wink:

Thank you in advanced!

1 Like

maybe a predictive function in chrome itself?

Aye… I’ve just tried removing several autofill settings from the chrome preferences but none of them seem to have any effect.

Is anybody else using the Apple Japanese Keyboard and the latest Chrome who could confirm whether or not they are experiencing this same issue?

Anybody at all?

The same issue with Japanese input is happening to me too. I am using Chrome on MacOS Sierra 10.12.4. Correct answers don’t trigger the problem, only incorrect answers.

The issue started just within the past week. I have not been able to figure it out either.

I just tried it in Safari without issue.

No answer here unfortunately, but I can confirm I’m experiencing the same thing.

OSX El Capitan 10.11.16 (15G1108)
Chrome Version 58.0.3029.110 (64-bit)

BUMP for Justice <3

I have the exact same issue, have been having it for a couple of months too and haven’t found any fix for it apart from using Safari instead. On Mac and using Chrome latest version.

It’s been more than a half year since this thread was opened and I still experience the same thing using Chrome (61.0.3163.100 ) on MacOSX (10.12.6).
Any new insights from anyone besides using a different browser?

Unfortunately not. I’ve seceded and use Safari instead for Memrise now…

Can confirm bug, and now not only in incorrect answers but in any answer.

Using latest Chrome up to date: Version 62.0.3202.94 (Official Build) (64-bit)
Using OSX Yosemite 10.10.5

1 Like

Same here, using Chrome and OS X El Capitan 10.11.6. Please help out with this - as DirtyWolf says, it’s also happening in some correct answers as well as incorrect answers and is making memrise almost totally unusable on Chrome.

I also encounter this problem when using the Japanese IME, which makes Memrise unusable.
Chrome 62.0.3202.94
macOs High Sierra 10.13.2

Same for me. It bugged me out so much that I had to switch to the app. Anybody came to a solution yet?

Mac Yosemite 10.10.5
Chrome: 62.0.3202.94

Hi, I also have this problem.
MacOS High Sierra Version 10.13.1
Google Chrome Version 63.0.3239.132 (Official Build) (64-bit)

Annoying Solution:
I can’t just turn off predictive text altogether, because I frequently use it for other purposes. So whenever I’m using Memrise, every time I see the little predictive text box pop up, I hit Escape key before I start typing. This solves the problem, sort of.

Annoying part 1: My predictive text is full of bullshit non-words from when I forget the Escape trick.

Annoying part 2: If the previous card was a multiple choice, hitting escape tells Memrise “I don’t know the answer” and moves the vocabulary card into the infuriating Difficult Words pile (which almost never contains anything but IME accidents like this).

So I guess it’s not really a solution. I’ll just keep trying to remember to use Safari.

Same problem on win10 with chrome for me.

Hi @Eltaurus,

Thanks for raising this.

Can you please confirm the link to the course where you experience this issue, so that we can test it?

Looking forward to hearing from you,
Memrise team

2 Likes

I’m not sure which course is it exactly, since I usually review words from all of them together. It is likely either of these two: * Beginners Japanese Particles 1 - by JTalkOnline.com - Memrise or JLPT N5 Grammar - by jlptbootcamp - Memrise. Or maybe both.

Thanks for getting back to us, @Eltaurus. I’ve now raised this bug to our developers, so they can begin looking into what is causing the issue (internal code QA-762). I’m afraid I don’t have a timeline for how long this will take, but please do look out for future updates :slight_smile: Thanks for your patience, Memrise team

1 Like