Android won't let me open a browser version, keeps opening the app

My device is a Stylo 5
My Memrise name is philiplang926
I currently have the memrise app for android. However, there is information that I can only see on the web based site so sometimes I need to go there (such as planning on when I’m due to review certain words). On either Brave browser or Google browser, when I try to login using my google account it keeps sending me to the app. I don’t want to use the app, I want to get on the browser version. I tried using Dolphin browser but when I click the google account log in, it just bumps me back to the home page and won’t let me log in.

So how do I get the browsers to let me log in on the browser version instead of default opening the app?

Hi Philip,

I have had a similar problem recently. After many attempts and a lot of wasted time, I was able to reach the website on my android phone using the url app.memrise.com (ignoring any of suggested links for the www.memrise.com url). On signing in, I still got directed to the android app at first but by going back to the search engine and tapping on the url box, I got taken to a list of my previously visited Memrise links which included one for app.memrise.com/home, which opened the website for me.

A much quicker (and less stressful) way is to unistall the android app, which then allows direct access to the website (using the app.memrise.com url) and then later to reinstall the android app.

I don’t know if this is a bug or an intentional way of pushing the android app but it’s very annoying!

Good luck!

@MemriseSupport - can you advise please?

3 Likes

Hi, unfortunately at the moment trying to log in on memrise.com on a mobile browser might launch the app by default. To avoid this from happening you can try using incognito mode or follow the steps below:

  • Go to your device Settings > Apps
  • Find Memrise in the list > Open by default > Open supported links > select “Ask every time” or “Don’t allow”

Please note that these instructions might differ based on the device you’re using.

Although this is not a bug, I appreciate it can be annoying so I’ll raise the feedback to the relevant team. Apologies for any inconvenience.

Best,
A.

5 Likes

Hi Alessio,

Thanks. For my device (Samsung Galaxy), I had to go: Settings>Apps … then Set as default>clear defaults>Go to supported URLs>Always ask

Then on the mobile browser, after typing user name and password, I needed to selet the “open with Samsung Internet” option. The “Memrise” icon option launched the app.

Yes, it is! :grimacing:

Thanks!

3 Likes

Hi @philiplang926, @alanh and @ale_c,

I have a Moto G7 Power running Android 10 and I use Firefox.

I have previously saved a shortcut to app.memrise.com/home on a screen, which is still working perfectly, letting me see Full Course descriptions, Multimedia levels, learn and review.

I too wish to refer to the web version from my Smart-phone on occasions (particularly as it lets me find and sort courses - (something I have raised recently underFeature Request ◄)).

I’m posting this from my phone. This means your solution worked. Thank you very much!

Essentially, the Chrome program opens the greater part of the sites in their connected applications as opposed to opening it as a site in the actual program.

1 Like