Android bugs

Just wondering: it seems to me that these have been fixed. Can you confirm this, @JBorrego?

  • #5 / scroll position within lists (not fixed, see further down)
  • #7 / moving between courses
  • #8 hitting the repeat-button too early

Not sure about most of the other open items.

I have a new issue that I have come across due to changing my learning approach.

I’m working on a bunch of (community) courses with hard to learn vocab. In order to better force stuff into my brain, I learn words. After the second cycle (all completely “learned”), I do between 1-3 speed review sessions on the level they are in.

Also, I tend to use the following procedure when working on those courses:

  • review any words up for review (SRS)
  • speed review over the last 1-2 levels and/or the course as a whole

Both the above procedures seem to prevent such repeated words from ever showing up on a standard review session - the regular review obviously only contains words that I either answered wrongly or that haven’t been repeated for a longer (!) time.
This leads me to the conclusion that a word’s SRS score is being updated (“watered”) every time you do a speed review.

Now I recall that you changed speed reviews in the not too distant past. A speed review will now repeat words that are up for review first, watering them along the way. Also, when a speed review is being used instead of a regular review, the speed review will only test the words that are up for review.
Thus, a speed review does update the SRS score of a word that was up for (classic) review.
While I suppose it’s OK to alternatively have a means of reviewing words via a speed review (handy for courses with hundreds or even thousands of words up for review), it’s very much preventing us from doing additional repetitions when repeating words that are not up for (SRS-) review.

Can you provide any insight into this, @JBorrego?

#5 It looks fine now, though I’m not sure if it has been fixed completely. See my comment here.

#7 I’m starting wrong/previous courses quite often, so it’s certainly not fixed.

#8 I recall that I saw this bug a long time ago, but not recently.

1 Like

Are you talking about the same problem I have mentioned here?

1 Like

Gee, you’re right! There’s actually two different issues - the one that I thought #5 referred to was the fact that, when moving from one course to a different one and then started a (whatever) session, that session was started with the formerly selected course, not the current one. So what I meant was actually #7, so cheers for correcting that!

I obviously completely misinterpreted your thread there. I was under the impression that the influence on SRS repetitions only affected words that were up for review. But I’m sure it affects words regardless of whether they’re up for review or not. I actually like the former, but the latter is effectively hindering one’s learning process.

I haven’t seen this issue ever since they changed the dashboard. It takes a while for me to locate “my next course” as I have to scroll like crazy, but once I pick a course, everything’s just fine.

Also, I have a couple of official courses which I keep in the loop (sorted from course 1 to 7 or in between, where appropriate), so I’ll check on the dashboard whether there’s any words up for review, then I select the first course (say “Swedish 1”). The course (due to having been finished) will scroll to the bottom which allows me to just tap the next course (i. e. “Swedish 2”).

Assuming the first course with words up for review is “Swedish 4” then I’d quickly change from 1 through 4 and then hit the “Review” button. This hasn’t been a problem as of yet.

In the begginning I had the same impression: it worked OK. At the moment I see this problem every now and then. Maybe they’ve changed something in latest updates?

Maybe you’re referring to the “timeout” problem, that is, the fact that the app seems to hang every now and then?

Nope, Olaf, I won’t confuse two of them. On my device previous course bug happens quite regularly, despite of the new dashboard. I had it 4-5 times yesterday. As for timeout/bad connection problem, yeah, saw it too, but that’s a different story.

1 Like

The word to be translated is cut off on a 4.6 inch screen (Xperia Z5 Compact Android 7.1.1)

1 Like

Hello, sorry if this is the wrong place for this but:
The audio almost never plays for the first second or so. It will play, but with the first part cut off. This is only an issue with Bluetooth, it seems to work fine when using my phone speaker. I tried searching for this issue and it looks like people were reporting this since 2017, but I couldn’t find a fix…
Memrise v. 2.94_19853
Moto g6, Android version 9, PPSS29.118-15-11-9

3 posts were split to a new topic: Learning words: fewer repetitions for official Memrise courses?

Sorry, @Gian_Ralph68, I completely overlooked your posting.
I have the same issue, but it’s nothing Memrise can do anything about as it is connected to the way the devices work. I’ve tried several devices and all have the exact same problem. Both with Memrise and Duolingo, BTW.

It could be connected to some sort of power-saving “feature”, i. e. the device turns off the radio connection right away when the sound stops and then needs some time to re-establish the connection.

1 Like

For about 2 or 3 weeks there’s a new problem: the app is very slow when loading the dashboard (3-5s) or when loading the chapters of a course, i. e. when switching to a different course (3s - ad infinitum!).

Very often I do have to kill the app and restart it as, otherwise, the spinning wait-indicator is all I get.
Sometimes I even have to restart the device!

Anybody else with this problem? I’ve seen it appear elsewhere too, i.e. here and here.

@MemriseSupport, @JBorrego (are you still around? Haven’t seen you in ages!): this is really getting more and more irritating. Please deal with this ASAP!

(Filed as #29 in the OP.)

2 Likes

Yes, exactly the same for me on both my android devices.
It is very frustrating especially when doing multiple courses.
While the chapters are attempting to load you can still start a review, new word etc. session or even try to switch to a different course.(strange)
it is also very slow loading a review or speed review session when there are no (scheduled) words to review.

1 Like

@MemriseSupport, @JBorrego et al: I can add that I cannot reliably reproduce the behaviour, but I very often get this when I change to a course and then tap i. e. the review icon without waiting for the course data to have loaded.

Another good way to produce this is by repeatedly starting and cancelling a learning session. This is what I often do in official Memrise courses when I want to go through, say, 3 new words and - due to the new “quick learning feature” I end up with two words that have been completely learned and one still requiring another appearance - I always try to have all new words learned completely, so I start a new learning session until that one word shows up. Usually it requires 1-5 sessions to see that word as the first one of the session.

Hi all,

Thanks for reaching out and apologies for the delayed response- it’s been a busy few weeks!

The Android team are definitely aware of the issues users are facing with loading times. A fix is being looked into, however we don’t have an expected timeframe for this at the moment unfortunately :frowning:

Once we have any updates on this, we will let you know.

Thanks so much for your patience,
Memrise team

3 Likes

Oh my god, what have you done! Yesterday’s update has dramatically made things even worse!
The load time (both when picking a course and when showing the course list) has almost doubled!

But even worse: I sometimes have to pick a course three or more times until it gets selected; many times, I’ll be left with the previously selected one.

Particularly when you tap on the link for a subsequent course in an official Memrise course (like from Italian 1 to 2), the app just ignores the new selection. Every single time.

During today’s session, this took me at least 20min plus just for selecting the courses that I wanted to learn or to just keep in my personal order, this is absolutely ridiculous and truly devastating!

And worst of all - I don’t see any enhancement to the previous version.
This is really getting unbearable.

2 Likes

Most of those problems were with us for a month or two, at least I don’t see big changes with the latest update. Could it be device related? I shoud add that loading issue devours my battery life like crazy.