Android bugs

Hey thanks for the tag.

Regarding #17, you’ll now have to tap on the flag next to the title of the course you’re learning to open the list of languages you are enrolled in.

About #18, I’m not quite sure if this change was intention or not. Would it be possible to send in a recording so I can send this to the QA team for further investigation?

13 Likes

So was this change intentional? Because often tapping the flag gets you to that course homepage instead of to the courses list.

Yeah, this is an intentional change.

You can still access that screen by tapping the course title.

13 Likes

Hi @Joshua,

Thanks for the replies on #17. As discussed in other threads, some of us are finding that tapping on the course icon or swiping right from it doesn’t always call up our course list. It can often take several attempts over several minutes for it to work, which can be time-consuming and frustrating. Is there anyway this can be made more intuitive? Also, the “Help” section needs updating to reflect the change, please.

5 Likes

Sure. I’ve recorded a little video that illustrates the problem (100% reproducible), but can’t seem to share insert it here (at least not from my tablet). I’ll try sending it on Monday when I’m back in my office.

1 Like

A post was merged into an existing topic: Problem navigating to my “Home” page of courses (on the Android App)

The majority of my courses of Memrise (japanese, french and italian) have the wrong review count in the app and the browser and it’s SO annoying. it will show that reviews are to be done but in reality you are finished. The review count is off, for example it shows 10 reviews, will stop after 7 and will always show you “3” - you can never get it to zero. Please fix it :frowning: I kknow other users that have that issue as well

1 Like

OK. What led me to think that this is a bug is the fact that, in the leaderboards, the week/month/all time button on the top right is not correctly right-aligned. Instead, there is a large gap. In earlier versions, the menu button (three vertical lines) was on the far right.

This is strange.

I had a look at one of my course which had 200 words due to review and reviewed them all. I compared both website and the application and they both show zero words due to review.

Here’s a screenshot of a course which has 3 words due to review in level 3.

Do you have the icon shown in the first screenshot on your home page?

Also can you check each levels and see if there are words due to review. You can do this by looking at flower located next to the word inside the level. The light petals mean the word is due for review and the dark means it’s not.

Here is another screenshot after review.

Here is the review count going down by 3 on Android.

Here is the review count going down by 3 on the website.



Can you also do these same steps with the problematic course to see whether the issue is with Android or Web.

21 Likes

Are these wrong counts in the official courses by Memrise? If I understand you correctly, it seems like you can not review grammar lessons. The reason is that there’s no review option for them yet, but numbers for review are showing up.

2 Likes

Hi at all, sorry I’ll add picture for the problem.

See here for example the official Memrise course for French 3 and French 4

Screenshot_20190415-154039|236x500

According to the overview French 3 should have 3 reviews open ( I have no grammar topics left)

However upon Detail I get this view with “Zero” open reviews. If I Start the reviews I would start a Set of random words that would not be up for Review now and It doesn’t reduce the Review count. So technically I have Zero reviews to do, yet it shows 3.

If I Do the same with French 4 which should have 1 Review it shows this one review

This is correct.
.

I have courses which even have the Review count up to 15 but actually there are nö reviews to do :frowning:

It happens here :
Japanese 0, Japanese 1, Japanese 2, Japanese 3. French 1-3 (4 and 5 are okay and go down to Zero). Italian 1.

It drives me nuts because it always shows more reviews than I have (for example when the view shows 6 and the second screen shows 3, it will automatically stop my review after these 3 words)

The same in the Browser Version and my friend has the same issue. We use different Devices and to be honest I assume everyone here has this issue and It was Just not solved until now…

As I said before, most likely it’s because of the grammar lessons which are not accessible for reviews. I have this issue in some of the offical courses, too. Take a look at this comment, it’s about the same problem.

3 Likes

Thank you for the input - It is strange however as the grammar for French 3, 4 and 5 are exactly the same (same courses to be done, or rather everything finished. ) - yet I have the problem only in one of these course (number 3). Is this solvable or do I have to live with this? :frowning:

Ah, I think I understand the issue now.

Thanks @Hombre_sin_nombre for pointing out that thread, it seems this is the exact same issue and thanks @Akiho for the screenshots.

I noticed in your first screenshot you have “Grammar” in the mode selector which isn’t present in French 4.

The first screenshot is French 1 and the second is French 4.

French 4 has a different type of “Grammar” which is called “Grammarbot” which is located at the bottom left of the screen.

It is possible the issue only exists in French 1 and other courses which contains “Grammar” because the review is unavailable. These words or phrases you learned in the Grammar are due for review however the functionality isn’t available yet.

I believe this might be the issue.

21 Likes

Hi @Olaf.Rabbachin - Aside from Josh’s responses above, I spoke to our QA lead who provided these answers:

1. Daily goal reached message appears way too early, too late or not at all.
We are introducing some changes to points. We will be assessing streaks and daily goals after this has gone out.

2. Updates/changes to course content are not propagated to app.
Other users in the thread cannot reproduce it, we cannot reproduce it.

3. Large courses cannot be downloaded (i.e. 5000 words courses)
Known issue. Courses with such large number of items (community courses) cannot be downloaded or can fail to download.

4. Difficult words sometimes need to be removed several times before they disappear from the list.
We are unable to reproduce it. We need more details / much more information.

5. The scroll position within lists (i.e. word lists in a course) is not maintained after showing an item and then returning to the list.
It is not a bug, it is the way it is implemented. Current level is the last level the user has interacted with (aka, has had a session with).

6. Courses that have been completed show as incomplete; hitting the learn-button then triggers an error.
Can we see more examples of this? (have there been any cases since Jan 19?)

7. When moving between courses, hitting i.e. the repeat-button may start a session for the wrong (i.e. the previously active) course, if the user has progressed in the active course and the app needs to scroll from lesson 1 to the current/next lesson (timing problem).
Maybe a video or screen recording could clarify this issue?

8. (related to topic above:) when hitting the repeat-button too early, the session will actually start a general repetition using ALL words instead of the words currently queued for repetition; if that happens, correct answers will score 45 points (= indicator); what’s very irritating: the count of pending repetitions will not decrease in general sessions, instead you’ll have to do the repetitions once again for those in queue.
Same as above.

9. “Learn with locals” seems to rarely appear; sometimes an error message appears when manually staring a session.
This was fixed in the latest update.

10. Images provided in an otherwise text-based course (i.e. as an additional column) don’t show in the app; they do show in the web-version. Example: “(une) voûte en berceau” in this course 3.
There are no plans for this behaviour to change.

11. repetition session: the score sometimes gets hidden; this applies to the score for a single task as well as to the overall score.
We can investigate this.

12. repetition sessions: the ‘can’t listen right now’ button isn’t shown at times (speaker button at the top right of the window)
Same as above, but this was made persistent long ago so it shouldn’t happen. Do you have any video’s or screen recordings?

13. Score tables: the column headers and controls are hidden; they (most of all times) only shown when scrolling to the top of the list (i…e #1)
Known issue, we have tickets for this but I am unsure about time-lines as it is not a priority.

14. Previously, the button underneath a task initially, read Skip, this is no longer the case - the button now always reads Continue and appears to be disabled - which it is not. Very much worse is the fact that, if the user skips the task, the correct solution is not being shown (see this posting 5).
Known issue. Should have been resolved in Jan / Feb. Please let us know if still present > provide screenshots / video.

15. With longer phrases (word order puzzles), the words may end up underneath the words that have already been added to the phrase, making it impossible to see the remaining words and difficult to touch on the tiny bit that is visible without removing previous words.
Known issue. Unresolved / unsure on time-lines.

16. Audio not working at times during review: sometimes (don’t see any obvious pattern), there is no audio during review sessions. Notable: the sound you get when you correctly answered a question is still being played. It seems that, when this happens, providing a wrong answer seems to re-activate audio.
Cannot reproduce.

17. Menu button missing: with the latest app update (layout changes, 12/04/2019), the menu button is gone. This applies to i. e. the top left of the main screen (tap to select the current course) and the leaderboard lists (tap to choose from week/month/all time). This change was intentional; the menu-button in leaderboards is somtimes (!) still missing though.
Intentional. We are reviewing this, no decisions taken yet.

18. The device keyboard is turned off between questions. If you brought up the device keyboard during review, difficult words, etc., it stayed active until you explicitly turned it off. 12/04/19 - it will always be turned off between questions.
Known issue. Unresolved / unsure on time-lines.


I hope this helps.

20 Likes

Hello @MemriseMatty,

considering the possibility that we’re only misunderstanding each other here: what I meant is the fact that, in the (Android) app, you have to log off and then log back in to receive updated content (such as new items and/or corrections) for courses. This is quite obnoxious as logging off resets all learning settings (such as words per learning session, words per review session, etc.) and one will always have to re-download offline courses.

If, during a review session, a word gets added to the DWL and you remove it again by tapping the flash symbol during the session, it will remain on the list nevertheless. Also, if you remove a word from the DWL while working through the items, you might have to deactivate/activate it several times until the count of DW (as displayed on the top) is adjusted accordingly. Likewise, when the count doesn’t change, a word will still be on the DWL even though the flash symbol is “off”.

I have 6 courses that have been finished but show up as unfinished. This applies to both official and community courses although there’s only 1 official course this applies to (Danish 1).
And yes, there’s at least one course that I finished after Jan. 19.
Here’s a screenshot:

It’s easy to reproduce. When course #1 is active, switch to a different course / #2. It needs to be one where the next learning session is “deeper down”, i. e. one with 40 or so levels and the next level to learn is near the end. When you switch to course #2, the app will load the course and then scroll up from level 1 to the next “open” level. If, during the scrolling, you start a new repetition session, that session will start for course #1 instead of course #a2

Some further info on this: it doesn’t only apply to the score and the “sound off” button but to the “show/hide keyboard” button as well.
This one is hard to reproduce - it happens intermittently.

Some further info: in a former version of the app, tapping the “Weiter”/“skip” button meant that you weren’t able to provide an answer. Consequently, the app showed the solution (much like the “show solution” button on the web). Tapping the button now will simply skip the word, meaning that its solution isn’t shown - in fact this simply treats the word as “not reviewed” which doesn’t make much sense.
Here’s a screenshot from a repetition session:

This has been posted numerous times on the forum! Again, this is an intermittently appearing problem (and a very nasty one). Sometimes, the sound will just stop. It seems that in these cases the app doesn’t even attempt to load the audio file anymore as, otherwise, there will be a slight delay until the sound is being played. When the audio is gone, there will be no delay - the app will just move on to the next word. This applies repetition as well as to learning sessions (in the latter, the speaker symbol shows an error message I think), but I don’t recall that it ever happened during a difficult words session.
It might take quite a few sessions to repro the behaviour! For instance, during my reviews this morning (10 courses) the problem occurred once. In these cases I close the app and start it again to make the problem disappear.

I left out all items where you actually confirm the problem but are unsure on time-lines.
Let me know if you have further questions.

3 Likes

I don’t know if it’s been reported already (not in this post anyway) but:
When I update/edit a mem on the website it doesn’t update on the app.
Which is especially annoying as you can’t create full mems from the app, and them not syncing to the site makes them absolutely useless. I always first make a placeholder on the app and then edit it on the website, but now only the app version is showing.

Examples.
These are the last two, how they appear on the site vs how they appear on the app

Screenshot_2019-04-23-19-00-28

2019_04_23_19_01_09_Greenshot

The bug, which exists since the update, was applied also to older mems which worked perfectly fine on the app before.

Have you checked whether this isn’t just another iteration of the bug that forces you to log off and back in to receive updated content in the app?

That would be weird as it got rid of updates I had previously already received. But no, I haven’t, perhaps I should.
EDIT: you were right indeed, relogging fixed it, so it must be part of that bug.

I can confirm number 6 as of the 24th of April for Memrise Mandarin 1 on computer.
Bummer for a paid app to still have this issue after so long. So many fewer features than I expected when I paid up - not chat bot or grammar bot access.