Android bugs

Nope, Olaf, I won’t confuse two of them. On my device previous course bug happens quite regularly, despite of the new dashboard. I had it 4-5 times yesterday. As for timeout/bad connection problem, yeah, saw it too, but that’s a different story.

1 Like

The word to be translated is cut off on a 4.6 inch screen (Xperia Z5 Compact Android 7.1.1)

1 Like

Hello, sorry if this is the wrong place for this but:
The audio almost never plays for the first second or so. It will play, but with the first part cut off. This is only an issue with Bluetooth, it seems to work fine when using my phone speaker. I tried searching for this issue and it looks like people were reporting this since 2017, but I couldn’t find a fix…
Memrise v. 2.94_19853
Moto g6, Android version 9, PPSS29.118-15-11-9

3 posts were split to a new topic: Learning words: fewer repetitions for official Memrise courses?

Sorry, @Gian_Ralph68, I completely overlooked your posting.
I have the same issue, but it’s nothing Memrise can do anything about as it is connected to the way the devices work. I’ve tried several devices and all have the exact same problem. Both with Memrise and Duolingo, BTW.

It could be connected to some sort of power-saving “feature”, i. e. the device turns off the radio connection right away when the sound stops and then needs some time to re-establish the connection.

1 Like

For about 2 or 3 weeks there’s a new problem: the app is very slow when loading the dashboard (3-5s) or when loading the chapters of a course, i. e. when switching to a different course (3s - ad infinitum!).

Very often I do have to kill the app and restart it as, otherwise, the spinning wait-indicator is all I get.
Sometimes I even have to restart the device!

Anybody else with this problem? I’ve seen it appear elsewhere too, i.e. here and here.

@MemriseSupport, @JBorrego (are you still around? Haven’t seen you in ages!): this is really getting more and more irritating. Please deal with this ASAP!

(Filed as #29 in the OP.)

2 Likes

Yes, exactly the same for me on both my android devices.
It is very frustrating especially when doing multiple courses.
While the chapters are attempting to load you can still start a review, new word etc. session or even try to switch to a different course.(strange)
it is also very slow loading a review or speed review session when there are no (scheduled) words to review.

1 Like

@MemriseSupport, @JBorrego et al: I can add that I cannot reliably reproduce the behaviour, but I very often get this when I change to a course and then tap i. e. the review icon without waiting for the course data to have loaded.

Another good way to produce this is by repeatedly starting and cancelling a learning session. This is what I often do in official Memrise courses when I want to go through, say, 3 new words and - due to the new “quick learning feature” I end up with two words that have been completely learned and one still requiring another appearance - I always try to have all new words learned completely, so I start a new learning session until that one word shows up. Usually it requires 1-5 sessions to see that word as the first one of the session.

Hi all,

Thanks for reaching out and apologies for the delayed response- it’s been a busy few weeks!

The Android team are definitely aware of the issues users are facing with loading times. A fix is being looked into, however we don’t have an expected timeframe for this at the moment unfortunately :frowning:

Once we have any updates on this, we will let you know.

Thanks so much for your patience,
Memrise team

3 Likes

Oh my god, what have you done! Yesterday’s update has dramatically made things even worse!
The load time (both when picking a course and when showing the course list) has almost doubled!

But even worse: I sometimes have to pick a course three or more times until it gets selected; many times, I’ll be left with the previously selected one.

Particularly when you tap on the link for a subsequent course in an official Memrise course (like from Italian 1 to 2), the app just ignores the new selection. Every single time.

During today’s session, this took me at least 20min plus just for selecting the courses that I wanted to learn or to just keep in my personal order, this is absolutely ridiculous and truly devastating!

And worst of all - I don’t see any enhancement to the previous version.
This is really getting unbearable.

2 Likes

Most of those problems were with us for a month or two, at least I don’t see big changes with the latest update. Could it be device related? I shoud add that loading issue devours my battery life like crazy.

I don’t think so. I just tried it on my phone (I use a tablet most of the time) and the “sticky course” problem is the same there.
Memrise has always been a tad quicker on my latest phone (Samsung Galaxy S10e), but I suppose that’s due to its superior CPU. Nothing serious though.

Are you saying you don’t have those problems at all? Are you on the latest version (2.94_22505)?

Yes, I have checked it, I have the same version. What I’m saying is these problems were here even before this update. I don’t see significant deterioration neither improvement.

To be more specific:

Likewise, it takes a very long time.

It appears on my side when I have bad internet connection.

Same thing here. I guess the only way to keep them in order and everything is to make “pinned” courses feature.

Well, it definitely takes a whole lot longer now, compared to yesterday. And I have a massive bandwidth here on my WLAN (250/25, with a short ping and very low latencies).

Also, I was able to iterate over the official Memrise courses from i. e. 1 to 7 and, for instance, do a review on part 3. If you now start out at 1 and tap from 1 to 2 and then from 2 to three, you’ll see that one is still active when you attempt to start a review on 3.
I’ve done it for ages this way, but as of today it’s no longer working.

Yep, tried it now with some courses, didn’t work for me, too. I’m staying on the previous course.

P.S. Olaf, could you use “reply to” button? I don’t see your posts in my notifications.

That’s quite odd. You can only reply by clicking either of the two reply buttons, so either a reply to a certain post (grayish Reply underneath a post) or to the thread in general (blue button at the bottom).
Both should result in a notification if you are watching the thread!

@MemriseSupport, @JBorrego: kudos - it seems the load time has been reduced drastically, and the problems when picking a course have gotten far better (albeit not completely resolved yet). That’s quite an enormous relief, so thank you guys, this really made my day! :smiley:

However, I noticed two things:

  • The links between official Memrise courses are gone, i. e. I can’t just tap to go from, say, Italian 1 to Italian 2 (the button is missing). Can you bring them back, please?
  • I haven’t done this in while, but yesterday I logged off and back on to receive updates across all my courses (which, sadly, still is the only way to do this). When I opened the app this morning, the progress across all courses was gone, as was the number of words up for repetition, etc. - the numbers reappeared only for the courses that were selected. This means that I’d have to select every single course (including the ones I’m not working on presently), to get their figures. It would be nice if that could be fixed with a future update.

Edit:
During today’s second session I came about something pretty strange: using my tablet, the app encountered some problem while loading a course. I tried to reload, I then closed the app and restarted it, to no avail: all I got was the hourglass, and the app didn’t allow me to do anything. Neither (hard) stopping the app nor restarting the device helped. I thus used my mobile and was astonished to see that, there, not only could I start the app, but also all data was present across all courses. I worked through 2 courses there and periodically checked whether I could start the app on the tablet, I then picked a course on the mobile that I had also worked on on the tablet, but neither worked.

I thus uninstalled and reinstalled the app on the tablet. Interestingly, I didn’t have to login there, but the app started without problems. However, it picked/activated the course which I end my sessions with, not the last active one on the mobile.
After a first session though, the order had been restored. But, again, all progress information on the tablet is gone whereas everything is OK on the mobile.

Very odd.

1 Like

The same thing occurred again today. After going through a bunch of courses, the app signalled a problem when selecting this course on my tablet:

After that, I couldn’t start the app anymore.
I was able to work on the course on my mobile though. On the tablet, I had to reinstall the app to make it work again.

There’s at least one other user with the same or at least a similar problem:

Just in case, nothing has changed on my side with both of these updates, but it took some time to start the app right now. I know from experience that when you don’t have internet connection you can only see a start page with Memrise logo.

Could it be that this problem is related to Memrise servers and whatnot, but not to the app itself? By the way, since recently it’s getting laggy when you are doing exercises, for instance, it responds to your answers milliseconds later than usual.

It could be. Over the past (almost) three years I’ve seen many problems in the app, but never one where my tablet and my mobile behaved differently, so that’s rather odd. The only thing I can think of is that my tablet’s memory is almost used to capacity, so I might have to try and remove some apps and see whether that changes anything.

Are you saying that you still see the links between official Memrise courses?
I must say, ever since the last update the speed issue is practically gone. I still have to select some courses more than once until I see their count of words up for review though.