Android app won't display courses

Just seeing if anyone else is having this problem. For a few days I can’t get it to display my courses on the app, it tries but then I get the error “sorry there was an error loading the content”. I tried restarting the app, restarting the phone, and uninstalling and re-installing the app. I can view my profile, leaderboard, and settings without any problem.

Just to make sure it wasn’t my wifi, I drove to the library and tried it there. Still no luck.

Hi there, sorry to hear that! Can you please provide more details, such as device, OS, app version and screenshots/videos of the issue?

We look forward to your response.

Best wishes,
Memrise team.

5 Likes

App version is 2.94_18361_memrise, phone is android version 6.0.1. I also put it on the tablet I bought yesterday, Android 8.1.0 and the same thing happens. I put it on my kindle fire this afternoon and it does work there.

1 Like

I just quit a whole lot of courses, and now it seems to be working again. Either it was coincidence, or I was my own enemy.

1 Like

I just installed the app yesterday after a hiatus and am having the same problem. Upgraded with the newest release today and it changed nothing. Really frustrating as I just signed up to pay for pro and can’t use the app… Submitted a bug report yesterday but not even an email to say it was received. Really @MemriseSupport ?

@FishSlap – I am interested in seeing if I can fix it by deleting some courses through the web interface (which is otherwise useless to me). What kind of stuff did you delete?

I deleted a lot of courses that I had completed and haven’t been periodically reviewing, and things that I simply lost interest in. It took a while because I’ve been using Memrise since there were about 30 French courses, and clearly I should have cleared out unused courses before now.
But I also noticed that there was a short outage yesterday, maybe it was just bad timing.

Thanks @FishSlap. This helped. It still wasn’t working for me after the outage was fixed, but I went in via the web today and quit a handful of courses. There were a couple of false starts where it loaded partially and then crashed. Then I deleted some more courses, and now it works.

@MemriseSupport – While I may have jusst been acting as a “hoarder”, I find it disconcerting that I would have to go through and delete courses to not have the application crash. I suspect you need to do something to handle your API calls more efficiently. Since the interface doesn’t let me make a distinction between courses I have worked on and courses I am actively working on, I don’t like deleting courses in case i need to go back to a language that has fallen inactive and want to review with those old decks. That’s a completely reasonable thing for someone to do, and I hope you guys design improvements to your interface so that people like me and @FishSlap can more easily sort through such things.

2 Likes

Hi there @xferguson, sorry to hear that. Can you please also confirm your device, OS, app version and screenshots/videos of the issue? I’ll create a ticket for our developers so that they can investigate further.

I look forward to your response.

6 Likes

As I said above, I had to quit a bunch of courses for the workaround, so I won’t be sending any screenshots. I am on an Android, moto g6, PDSS29.118-15-11-9. Dos you not receive the support ticket / bug report I placed on this problem last week (which had all the above info?)

This post was flagged by the community and is temporarily hidden.