3-button questions won't work with keyboard (any course)

Note: This is on the computer.

The test questions to listen and choose one option won’t produce any audio if you press the 1 to 3 keys on your keyboard, you need to click with the mouse.

This started happening about 2 or 3 days ago and worked perfectly until then.

Hi, do you mean a listening test like this? It’s currently working fine for me, could you give me a bit more information so I can help you please?

Yep, that’s the one.
It happens in Italian 1/2, English 1/2, American English 1 and Portuguese 1.
OK, maybe it’s something in my browser (Firefox). I’ll try with a clean installation and report back if I find anything.
Thanks for answering.

I’ve just checked it on Firefox on a Mac and it seems to work fine.
If it persists after you reinstall please let me know, including which operating system you’re on so we can try and reproduce. I can’t immediately see any changes we’ve made that would have done this, but it’s always possible.

Sorry, I forgot: Windows 10 and Firefox 110.

I have checked it on Firefox 110 on a Windows 11 device and it worked fine.
I don’t have a windows 10 device immediately available to check, but I remember we have had one similar bug with button accessibility on windows 10 firefox that we have been unavailable to fix as firefox behaved differently to all other browsers on windows 10, but not windows 11 in that regard.
I will ask the team if there’s anything to be done, but due to it’s small market share (around 1.5% of our users if you include all operating systems) we don’t officially support Firefox. And as this is only on the windows 10 share of that 1.5%, it’s unlikely we’ll be able to make a custom fix.

Ok, it looks like it’s solved. And I’m the one to blame. :grinning:
I’ll leave this in case it’s useful for anyone else that has this problem.

So there’s this Firefox addon called “Disable HTML5 Autoplay” that I installed to stop .mp4 videos from auto play that I’m using for a project. Long story short, the addon stops the audio from Memrise. But not all, just when you try to listen using the keyboard, not the mouse. So weird.

So you can disable / uninstall the addon or go to the addon menu while in the Memrise webpage and uncheck “Disable autoplay”. No more headaches.

1 Like